Saturday, December 31, 2011

Microsoft Security Bulletin Alert and security updates -29122011

Microsoft Security Bulletin MS11-100 - Critical

Vulnerabilities in .NET Framework Could Allow Elevation of Privilege (2638420)

Published: | Updated:
Version: 1.1

General Information

Executive Summary

This security update resolves one publicly disclosed vulnerability and three privately reported vulnerabilities in Microsoft .NET Framework. The most severe of these vulnerabilities could allow elevation of privilege if an unauthenticated attacker sends a specially crafted web request to the target site. An attacker who successfully exploited this vulnerability could take any action in the context of an existing account on the ASP.NET site, including executing arbitrary commands. In order to exploit this vulnerability, an attacker must be able to register an account on the ASP.NET site, and must know an existing user name.
This security update is rated Critical for Microsoft .NET Framework 1.1 Service Pack 1, Microsoft .NET Framework 2.0 Service Pack 2, Microsoft .NET Framework 3.5 Service Pack 1, Microsoft .NET Framework 3.5.1, and Microsoft .NET Framework 4 on all supported editions of Microsoft Windows. For more information, see the subsection, Affected and Non-Affected Software, in this section.
The security update addresses the vulnerabilities by correcting how the .NET Framework handles specially crafted requests, and how the ASP.NET Framework authenticates users and handles cached content. For more information about the vulnerabilities, see the Frequently Asked Questions (FAQ) subsection for the specific vulnerability entry under the next section, Vulnerability Information.
This security update also addresses the vulnerability first described in Microsoft Security Advisory 2659883.
Recommendation. The majority of customers have automatic updating enabled and will not need to take any action because this security update will be downloaded and installed automatically. Customers who have not enabled automatic updating need to check for updates and install this update manually. For information about specific configuration options in automatic updating, see Microsoft Knowledge Base Article 294871.
For administrators and enterprise installations, or end users who want to install this security update manually, Microsoft recommends that customers consider applying the security update using update management software, or by checking for updates using the Microsoft Update service.
See also the section, Detection and Deployment Tools and Guidance, later in this bulletin.
Known Issues. Microsoft Knowledge Base Article 2638420 documents the currently known issues that customers may experience when installing this security update. The article also documents recommended solutions for these issues.

Affected and Non-Affected Software

The following software have been tested to determine which versions or editions are affected. Other versions or editions are either past their support life cycle or are not affected. To determine the support life cycle for your software version or edition, visit Microsoft Support Lifecycle.
Affected Software
Operating SystemComponentMaximum Security ImpactAggregate Severity RatingBulletins Replaced by this Update
Windows XP
Windows XP Service Pack 3Microsoft .NET Framework 1.1 Service Pack 1
(KB2656353)

Microsoft .NET Framework 2.0 Service Pack 2
(KB2656352)

Microsoft .NET Framework 3.5 Service Pack 1
(KB2657424)

Microsoft .NET Framework 4[1]
(KB2656351)
Elevation of PrivilegeCriticalKB2572067 in MS11-078 replaced by KB2656353

KB2418241 in MS10-070 and KB982167 in Security Advisory 973811 replaced by KB2656352

KB2416473 in MS10-070 replaced by KB2657424

KB2416472 in MS10-070 replaced by KB2656351
Windows XP Professional x64 Edition Service Pack 2Microsoft .NET Framework 1.1 Service Pack 1
(KB2656353)

Microsoft .NET Framework 2.0 Service Pack 2
(KB2656352)

Microsoft .NET Framework 3.5 Service Pack 1
(KB2657424)

Microsoft .NET Framework 4[1]
(KB2656351)
Elevation of PrivilegeCriticalKB2572067 in MS11-078 replaced by KB2656353

KB2418241 in MS10-070 and KB982167 in 973811 replaced by KB2656352

KB2416473 in MS10-070 replaced by KB2657424

KB2416472 in MS10-070 replaced by KB2656351
Windows Server 2003
Windows Server 2003 Service Pack 2Microsoft .NET Framework 1.1 Service Pack 1
(KB2656358)

Microsoft .NET Framework 2.0 Service Pack 2
(KB2656352)

Microsoft .NET Framework 3.5 Service Pack 1
(KB2657424)

Microsoft .NET Framework 4[1]
(KB2656351)
Elevation of PrivilegeCriticalKB2416451 in MS10-070 replaced by KB2656358

KB2418241 in MS10-070 and KB982167 in Security Advisory 973811 replaced by KB2656352

KB2416473 in MS10-070 replaced by KB2657424

KB2416472 in MS10-070 replaced by KB2656351
Windows Server 2003 x64 Edition Service Pack 2Microsoft .NET Framework 1.1 Service Pack 1
(KB2656353)

Microsoft .NET Framework 2.0 Service Pack 2
(KB2656352)

Microsoft .NET Framework 3.5 Service Pack 1
(KB2657424)

Microsoft .NET Framework 4[1]
(KB2656351)
Elevation of PrivilegeCriticalKB2572067 in MS11-078 replaced by KB2656353

KB2418241 in MS10-070 and KB982167 in 973811 replaced by KB2656352

KB2416473 in MS10-070 replaced by KB2657424

KB2416472 in MS10-070 replaced by KB2656351
Windows Server 2003 with SP2 for Itanium-based SystemsMicrosoft .NET Framework 1.1 Service Pack 1
(KB2656353)

Microsoft .NET Framework 2.0 Service Pack 2
(KB2656352)

Microsoft .NET Framework 3.5 Service Pack 1
(KB2657424)

Microsoft .NET Framework 4[1]
(KB2656351)
Elevation of PrivilegeCriticalKB2572067 in MS11-078 replaced by KB2656353

KB2418241 in MS10-070 and KB982167 in Security Advisory 973811 replaced by KB2656352

KB2416473 in MS10-070 replaced by KB2657424

KB2416472 in MS10-070 replaced by KB2656351
Windows Vista
Windows Vista Service Pack 2Microsoft .NET Framework 1.1 Service Pack 1
(KB2656353)

Microsoft .NET Framework 2.0 Service Pack 2
(KB2656362)

Microsoft .NET Framework 3.5 Service Pack 1
(KB2657424)

Microsoft .NET Framework 4[1]
(KB2656351)
Elevation of PrivilegeCriticalKB2572067 in MS11-078 replaced by KB2656353

KB2416470 in MS10-070 and KB982533 in Security Advisory 973811 replaced by KB2656362

KB2416473 in MS10-070 replaced by KB2657424

KB2416472 in MS10-070 replaced by KB2656351
Windows Vista x64 Edition Service Pack 2Microsoft .NET Framework 1.1 Service Pack 1
(KB2656353)

Microsoft .NET Framework 2.0 Service Pack 2
(KB2656362)

Microsoft .NET Framework 3.5 Service Pack 1
(KB2657424)

Microsoft .NET Framework 4[1]
(KB2656351)
Elevation of PrivilegeCriticalKB2572067 in MS11-078 replaced by KB2656353

KB2416470 in MS10-070 and KB982533 in 973811 replaced by KB2656362

KB2416473 in MS10-070 replaced by KB2657424

KB2416472 in MS10-070 replaced by KB2656351
Windows Server 2008
Windows Server 2008 for 32-bit Systems Service Pack 2Microsoft .NET Framework 1.1 Service Pack 1**
(KB2656353)

Microsoft .NET Framework 2.0 Service Pack 2**
(KB2656362)

Microsoft .NET Framework 3.5 Service Pack 1**
(KB2657424)

Microsoft .NET Framework 4**[1]
(KB2656351)
Elevation of PrivilegeCriticalKB2572067 in MS11-078 replaced by KB2656353

KB2416470 in MS10-070 and KB982533 in Security Advisory 973811 replaced by KB2656362

KB2416473 in MS10-070 replaced by KB2657424

KB2416472 in MS10-070 replaced by KB2656351
Windows Server 2008 for x64-based Systems Service Pack 2Microsoft .NET Framework 1.1 Service Pack 1**
(KB2656353)

Microsoft .NET Framework 2.0 Service Pack 2**
(KB2656362)

Microsoft .NET Framework 3.5 Service Pack 1**
(KB2657424)

Microsoft .NET Framework 4**[1]
(KB2656351)
Elevation of PrivilegeCriticalKB2572067 in MS11-078 replaced by KB2656353

KB2416470 in MS10-070 and KB982533 in Security Advisory 973811 replaced by KB2656362

KB2416473 in MS10-070 replaced by KB2657424

KB2416472 in MS10-070 replaced by KB2656351
Windows Server 2008 for Itanium-based Systems Service Pack 2Microsoft .NET Framework 1.1 Service Pack 1
(KB2656353)

Microsoft .NET Framework 2.0 Service Pack 2
(KB2656362)

Microsoft .NET Framework 3.5 Service Pack 1
(KB2657424)

Microsoft .NET Framework 4[1]
(KB2656351)
Elevation of PrivilegeCriticalKB2572067 in MS11-078 replaced by KB2656353

KB2416470 in MS10-070 and KB982533 in 973811 replaced by KB2656362

KB2416473 in MS10-070 replaced by KB2657424

KB2416472 in MS10-070 replaced by KB2656351
Windows 7
Windows 7 for 32-bit SystemsMicrosoft .NET Framework 3.5.1
(KB2656355)

Microsoft .NET Framework 4[1]
(KB2656351)
Elevation of PrivilegeCriticalKB2416471 in MS10-070 replaced by KB2656355

KB2416472 in MS10-070 replaced by KB2656351
Windows 7 for 32-bit Systems Service Pack 1Microsoft .NET Framework 3.5.1
(KB2656356)

Microsoft .NET Framework 4[1]
(KB2656351)
Elevation of PrivilegeCriticalNo bulletin replaced by KB2656356

KB2416472 in MS10-070 replaced by KB2656351
Windows 7 for x64-based SystemsMicrosoft .NET Framework 3.5.1
(KB2656355)

Microsoft .NET Framework 4[1]
(KB2656351)
Elevation of PrivilegeCriticalKB2416471 in MS10-070 replaced by KB2656355

KB2416472 in MS10-070 replaced by KB2656351
Windows 7 for x64-based Systems Service Pack 1Microsoft .NET Framework 3.5.1
(KB2656356)

Microsoft .NET Framework 4[1]
(KB2656351)
Elevation of PrivilegeCriticalNo bulletin replaced by KB2656356

KB2416472 in MS10-070 replaced by KB2656351
Windows Server 2008 R2
Windows Server 2008 R2 for x64-based SystemsMicrosoft .NET Framework 3.5.1*
(KB2656355)

Microsoft .NET Framework 4[1]
(KB2656351)
Elevation of PrivilegeCriticalKB2416471 in MS10-070 replaced by KB2656355

KB2416472 in MS10-070 replaced by KB2656351
Windows Server 2008 R2 for x64-based Systems Service Pack 1Microsoft .NET Framework 3.5.1*
(KB2656356)

Microsoft .NET Framework 4*[1]
(KB2656351)
Elevation of PrivilegeCriticalNo bulletin replaced by KB2656356

KB2416472 in MS10-070 replaced by KB2656351
Windows Server 2008 R2 for Itanium-based SystemsMicrosoft .NET Framework 3.5.1
(KB2656355)

Microsoft .NET Framework 4[1]
(KB2656351)
Elevation of PrivilegeCriticalKB2416471 in MS10-070 replaced by KB2656355

KB2416472 in MS10-070 replaced by KB2656351
Windows Server 2008 R2 for Itanium-based Systems Service Pack 1Microsoft .NET Framework 3.5.1
(KB2656356)

Microsoft .NET Framework 4[1]
(KB2656351)
Elevation of PrivilegeCriticalNo bulletin replaced by KB2656356

KB2416472 in MS10-070 replaced by KB2656351
*Server Core installation affected. This update applies, with the same severity rating, to supported editions of Windows Server 2008 or Windows Server 2008 R2 as indicated, whether or not installed using the Server Core installation option. For more information on this installation option, see the TechNet articles, Managing a Server Core Installation and Servicing a Server Core Installation. Note that the Server Core installation option does not apply to certain editions of Windows Server 2008 and Windows Server 2008 R2; see Compare Server Core Installation Options.
**Server Core installation not affected. The vulnerabilities addressed by this update do not affect supported editions of Windows Server 2008 or Windows Server 2008 R2 as indicated, when installed using the Server Core installation option. For more information on this installation option, see the TechNet articles, Managing a Server Core Installation and Servicing a Server Core Installation. Note that the Server Core installation option does not apply to certain editions of Windows Server 2008 and Windows Server 2008 R2; see Compare Server Core Installation Options.
[1].NET Framework 4 and .NET Framework 4 Client Profile affected. The .NET Framework version 4 redistributable packages are available in two profiles: .NET Framework 4 and .NET Framework 4 Client Profile. .NET Framework 4 Client Profile is a subset of .NET Framework 4. The vulnerability addressed in this update affects both .NET Framework 4 and .NET Framework 4 Client Profile. For more information, see the MSDN article, Installing the .NET Framework.

0 Responses to “Microsoft Security Bulletin Alert and security updates -29122011”